More Awesome Than You!
Welcome, Guest. Please login or register.
2020 September 28, 18:38:17

Login with username, password and session length
Search:     Advanced search
540025 Posts in 18039 Topics by 7924 Members
Latest Member: lassieravendancer
* Home Help Search Login Register
+  More Awesome Than You!
|-+  TS2: Burnination
| |-+  The Podium
| | |-+  Oops! You Broke It!
| | | |-+  Lag (black screen) while loading
0 Members and 1 Guest are viewing this topic. « previous next »
Pages: [1] THANKS THIS IS GREAT Print
Author Topic: Lag (black screen) while loading  (Read 7002 times)
Nova
Corpulent Cretin
*
Posts: 117



View Profile
Lag (black screen) while loading
« on: 2009 December 28, 05:24:34 »
THANKS THIS IS GREAT

Up until a few months ago, my game ran very smoothly.  It took my game a minute to get from clicking the desktop shortcut to entering a neighborhood.  Now I am stuck with an infuriating problem.  My game suffers from an unsightly black screen that pops up right after I hit the shortcut.  The blackness will last from one minute to three, after which it  continues on to the EA logo and loading screen.

The tech side of things:   The game and packs are bought legally.  I do have an EP9 no cd crack exe.  I have tried other cracks and they produce the same result.  Using the game's original disc to load also leads to the black lagging screen issue.

I am very impatient and I want my short and snappy load time back! {insert dramatic tears here} If anybody has any comments or suggestions to aid me in finding a solution, please step forward.  My last resort will be to uninstall and reinstall.  Must. Not. Happen.
Logged
J. M. Pescado
Fat Obstreperous Jerk
El Presidente
*****
Posts: 26225



View Profile
Re: Lag (black screen) while loading
« Reply #1 on: 2009 December 28, 08:32:20 »
THANKS THIS IS GREAT

You still get an EA logo, apparently. Have you tried deleting all the intro movies entirely, so it will skip straight to the load screen?
Logged

Grant me the serenity to accept the things I cannot change, the courage to change the things I cannot accept, and the wisdom to hide the bodies of those I had to kill because they pissed me off.
Nova
Corpulent Cretin
*
Posts: 117



View Profile
Re: Lag (black screen) while loading
« Reply #2 on: 2009 December 28, 17:16:24 »
THANKS THIS IS GREAT

Yes.  From this folder, correct?  C:\Program Files (x86)\EA GAMES\The Sims 2 Double Deluxe\Base\TSData\Res\Movies

I already had them out of that folder.  Is there another folder I am supposed to be deleting them from?
Logged
Marvin Kosh
Feckless Fool
*
Posts: 264



View Profile WWW
Re: Lag (black screen) while loading
« Reply #3 on: 2009 December 30, 07:26:04 »
THANKS THIS IS GREAT

You also want to remove them from the directory of the latest expansion, if present.
Logged

Nova
Corpulent Cretin
*
Posts: 117



View Profile
Re: Lag (black screen) while loading
« Reply #4 on: 2009 December 30, 17:18:00 »
THANKS THIS IS GREAT

All of them are out of the folders, but the problem remains.  Every single time I see that black screen my blood pressure shoots through the roof.  I know there is an easy solution.  Now to find it.

Edit:  Zero downloads.  Super vanilla.
« Last Edit: 2009 December 30, 17:23:19 by Nova » Logged
J. M. Pescado
Fat Obstreperous Jerk
El Presidente
*****
Posts: 26225



View Profile
Re: Lag (black screen) while loading
« Reply #5 on: 2009 December 31, 01:38:38 »
THANKS THIS IS GREAT

My guess is that your problem is hardware. Some piece of hardware is damaged and not running as quickly as it should be, forcing the computer to wait for it. Aging hard drives sometimes develop bad spots which take longer to read, and if your data is in one of those spots, it may suddenly develop hiccups as it reads. This is generally a precursor to total drive failure. Have that checked out.
Logged

Grant me the serenity to accept the things I cannot change, the courage to change the things I cannot accept, and the wisdom to hide the bodies of those I had to kill because they pissed me off.
Nova
Corpulent Cretin
*
Posts: 117



View Profile
Re: Lag (black screen) while loading
« Reply #6 on: 2009 December 31, 02:29:00 »
THANKS THIS IS GREAT

Hmm.  I loaded the game on my new computer a few months ago, and the problem started happening shortly after install.  If the comp is already conking out, watch out for a raging lunatic.
Logged
leaths
Corpulent Cretin
*
Posts: 100


Groovy


View Profile
Re: Lag (black screen) while loading
« Reply #7 on: 2009 December 31, 03:53:07 »
THANKS THIS IS GREAT

Are you running Vista? I have the same problem. On my old computer (with XP) the game started up fine. When I got my new PC (with Vista), the first few times the game loaded quickly, then suddenly started getting that black screen before loading. It doesn't last long for me--five seconds tops--but it is annoying. I could never figure out what caused it, nor could I ever make it stop--although it doesn't happen in windowed mode. I just chalked it up either to a quirk in Vista or my graphics card.
Logged
Nova
Corpulent Cretin
*
Posts: 117



View Profile
Re: Lag (black screen) while loading
« Reply #8 on: 2009 December 31, 05:25:54 »
THANKS THIS IS GREAT

Yup, Vista for me.  When I load the game in windowed mode, the black screen doesn't appear.  However, the game just sits in the background (doing nothing) for up to a minute before the window will pop up on the screen.  Once the window pops up, first the EA logo flashes, then the regular loading screen appears.

Logged
GelatinousSubstance
Exasperating Eyesore
*
Posts: 225


View Profile
Re: Lag (black screen) while loading
« Reply #9 on: 2009 December 31, 19:35:10 »
THANKS THIS IS GREAT

I had two similar problems with an AMD quad core and an nVidia Video card.

With Vista, the screen would go white (which bothers me more because I have sensitive eyes). It does the same thing on my daughter's laptop.

When I switched over to windows 7, the screen goes black for the first bit now, which it also does on my husband's computer.

All these systems are fairly new (less than a year old), and all have AMD CPUs (with different numbers of cores) and nVidia video cards of varying models (if that helps to find a common denominator).

My best guess is that it's either hardware or driver (or both) related.

Other than it being annoying to the user though, there isn't much to worry about.
Logged

Doctor: "He was lucky... He was shot in the 90% of the brain that he wasn't using..."

There is no shame in not being ashamed.
Nova
Corpulent Cretin
*
Posts: 117



View Profile
Re: Lag (black screen) while loading
« Reply #10 on: 2009 December 31, 20:03:20 »
THANKS THIS IS GREAT

Intel and nvidia for this girl.  You all are freaking me out about the hardware problem scenario.  I'm thinking a backup is in order.  Like now.
Logged
GelatinousSubstance
Exasperating Eyesore
*
Posts: 225


View Profile
Re: Lag (black screen) while loading
« Reply #11 on: 2009 December 31, 20:36:16 »
THANKS THIS IS GREAT

Backups are always in order, regardless of the situation.

However, I don't think you need to panic. What you're experiencing is a common phenomenon among the newer machines and the newer drivers. It doesn't mean your computer's going to explode. It just means it's going to annoy you, and that your head may explode. Nothing serious, seriously.

Did you install a new driver or allow a Windows Update recently? The root of the problem probably points to software drivers and particular models of nVidia - from the sounds of it - and you're probably just going to have to suck it up and deal with it.
Logged

Doctor: "He was lucky... He was shot in the 90% of the brain that he wasn't using..."

There is no shame in not being ashamed.
leaths
Corpulent Cretin
*
Posts: 100


Groovy


View Profile
Re: Lag (black screen) while loading
« Reply #12 on: 2009 December 31, 22:51:38 »
THANKS THIS IS GREAT

I'm running an Nvidia GeForce 9500 GT and an AMD processor (triple core). I have updated the graphics driver within recent memory, but IIRC, this starting happening before the update.

I agree that it seems like it's merely a visual annoyance and not sign of impending failure.
Logged
Nova
Corpulent Cretin
*
Posts: 117



View Profile
Re: Lag (black screen) while loading
« Reply #13 on: 2010 January 01, 00:51:42 »
THANKS THIS IS GREAT

Well, I have hope after the last few posts.  I also wondered if it could be a video driver issue, but my machine is being uncooperative in updating drivers right now.  I'll try and check it out at a later date, as I'm out of town and don't want to totally screw things up without my backups. 

The perplexing thing is the fact that after I installed the game, it was loading perfectly fine.  Out of nowhere, poof.  Black screen. 

Head explosion or computer explosion.  As sick as this is, I'll take the former.   Tongue
Logged
GelatinousSubstance
Exasperating Eyesore
*
Posts: 225


View Profile
Re: Lag (black screen) while loading
« Reply #14 on: 2010 January 01, 20:16:39 »
THANKS THIS IS GREAT

I thought you'd be interested in knowing that it would appear the nVidia driver I was using was at fault. I was curious after this post and just updated my driver to the most recent one.

Version: 195.62 WHQL
   
Release Date: 2009.11.26

The black screen seems to have disappeared.

I never really paid it much mind because it was happening on all my machines, except for one, and I just decided to accept it since it seemed like something I was stuck with and caused no real issues other than a small annoyance.
Logged

Doctor: "He was lucky... He was shot in the 90% of the brain that he wasn't using..."

There is no shame in not being ashamed.
Nova
Corpulent Cretin
*
Posts: 117



View Profile
Re: Lag (black screen) while loading
« Reply #15 on: 2010 January 01, 23:25:50 »
THANKS THIS IS GREAT

Hope!  I'm giong to try one more time to download that update.  I had kind of a mess the last time I made an attempt, so hopefully things will go better now.

Edited to add that the driver installation worked, but the black screen remains.  Back to square one.
« Last Edit: 2010 January 02, 02:56:59 by Nova » Logged
GelatinousSubstance
Exasperating Eyesore
*
Posts: 225


View Profile
Re: Lag (black screen) while loading
« Reply #16 on: 2010 January 02, 04:43:19 »
THANKS THIS IS GREAT

Did you uninstall the previous video driver before installing the new one?

If you don't uninstall the previous driver, previous issues may remain.
Logged

Doctor: "He was lucky... He was shot in the 90% of the brain that he wasn't using..."

There is no shame in not being ashamed.
Nova
Corpulent Cretin
*
Posts: 117



View Profile
Re: Lag (black screen) while loading
« Reply #17 on: 2010 January 03, 02:50:23 »
THANKS THIS IS GREAT

I sure did.  I'm glad your problems have vanished.  Nice to know somebody can load their game without wanting to throw a large tv out the window.
Logged
Alex
Malodorous Moron
***
Posts: 703


View Profile
Re: Lag (black screen) while loading
« Reply #18 on: 2010 January 12, 16:41:04 »
THANKS THIS IS GREAT

I'm also getting this. Win7 Ult 64, AMD and Nvidia here. While I agree it seems to be relatively harmless, it is weird and annoying.
Logged
Pages: [1] Print 
« previous next »
Jump to:  

Powered by MySQL Powered by PHP Powered by SMF 1.1.21 | SMF © 2015, Simple Machines Valid XHTML 1.0! Valid CSS!
Page created in 0.243 seconds with 21 queries.